Thread Tools
Posts: 4 | Thanked: 13 times | Joined on May 2018
I ran into a problem (multiple actually) while trying to get Sailfish on my new Fairphone.

Steps taken :
  1. Buy and receive new Fairphone2
  2. Boot it once or twice to it's stock Android
  3. Run the proximity sensor calibration item in the configuration settings
  4. Continue with the steps from
  5. Download
  6. fastboot flash modem ./BP/NON-HLOS.bin
  7. fastboot flash system system.img
  8. fastboot flash recovery recovery.img
  9. fastboot reboot
  10. See that device no longer boots and just says "loading"
  11. Notice that going to TWRP using volume up just makes my screen blue
  12. Download newest TWRP from
  13. fastboot flash recovery twrp-3.2.1-0-FP2.img
  14. fastboot reboot
  15. Notice I can now get to twrp, no longer blue
  16. Notice twrp won't mount my SD card
  17. reformat SD card to FAT32 on a 10GB partition (because Windows)
  18. Click install in TWRP, choose the zip file for Sailfish downloaded earlier
  19. Wait until finished and reboot
  20. See just the fairphone logo and rebooting after about a minute back to recovery...

I think I made a mistake and should have used the system and recovery from the other zip file linked at the page so I will flash those now and see if that helps...

But I'm annoyed at the lack of visibility of the boot process errors...

EDIT : nvm it works now - flashing the right system & recovery did the trick. I haven't checked if the recovery is still twrp now...

One remark for the guide - I don't know who or where to put this so the right people see it - it says : "Also the other partitions (except modem and boot partitions) can be flashed (rpm, sbl1, tz, splash and aboot) can be flashed " and about ten lines higher it says "Only flash system.img and recovery.img. DO NOT flash other partitions. " ... I think there's a copy paste error there? It seems a contradiction.

It does crash a lot...
Once while I was messing around with the camera and film roll, once while I was adding a contact (I didn't completely reboot but the GUI seemed to have crashed or something) and I think once more but I forgot what I was doing.
Also I've noticed I can't shut it says goodbye but then it reboots everytime?

Last edited by Rygir; 2018-05-31 at 20:33.

The Following 3 Users Say Thank You to Rygir For This Useful Post:
Posts: 506 | Thanked: 978 times | Joined on Aug 2014
Originally Posted by Rygir View Post
Also I've noticed I can't shut it says goodbye but then it reboots everytime?
It is the newest camera module upon FP2 which causes this issue with both SailfishOS and LineageOS as here:

I'll try to find appropriate link appertaining to Fairphone later, but don't find this "discourse" forum very user-friendly to navigate through.

As promised here is appropriate forum.fairphone link:

Last edited by aspergerguy; 2018-06-01 at 18:40. Reason: addition

The Following 3 Users Say Thank You to aspergerguy For This Useful Post:

fairphone, fairphone 2, sailfish os

Thread Tools

Forum Jump

All times are GMT. The time now is 14:48.