Notices


Reply
Thread Tools
Posts: 3 | Thanked: 7 times | Joined on May 2018
#311
Originally Posted by minimec View Post
First, welcome to talk.maemo.org.

I also use the Nexus 5 for a long time as daily driver. Same as @claustn, I am still on the CM12 base, mainly because af Video recording, but also because I am just lazy, and my CM12 configuration is running so smooth.

There are some things to mention. The last running version of SailfishOS on the CM12 base is 2.0.5.6 Haapajoki (@claustn: correct me if I am wrong ;-) ) You will also have to add a systemd service to enable bluetooth low-power-mode (see next post).

I am on my way to switch to the CM13 base, because a lot of apps I use have been upgraded and are no longer compatible with SFOS 2.0.5.6. So I have to use the old versions. Also I cannot remember having recorded a video with my cam... :-)

I hope you enjoy your Nexus 5 running SailfishOS.
Thank you for the info . I just installed sailfish. I am on 2.0.4.13 version so where can I find 2.0.5.6? And can i dirty flash it or i have to do clean install. Does sailfish support Viber and how to install it?
I am full of questions sry if I am bothering you
 

The Following User Says Thank You to Lakija For This Useful Post:
Posts: 89 | Thanked: 286 times | Joined on Feb 2012 @ Switzerland
#312
Originally Posted by Lakija View Post
Thank you for the info . I just installed sailfish. I am on 2.0.4.13 version so where can I find 2.0.5.6? And can i dirty flash it or i have to do clean install. Does sailfish support Viber and how to install it?
I am full of questions sry if I am bothering you
Source: http://talk.maemo.org/showpost.php?p...85&postcount=1 #OTA Update Support:

Code:
# New version
ssu release 2.0.5.6

# Set correct repositories
devel-su sed -i -e 's#^adaptation=.*$#adaptation=http://repo.merproject.org/obs/home:/RealJohnGalt:/testing:/hammerhead/sailfish_latest_armv7hl/#' /usr/share/ssu/repos.ini

ssu dr mw

ssu ar mw http://repo.merproject.org/obs/nemo:/devel:/hw:/common/sailfish_latest_armv7hl/

# Refresh package database
pkcon refresh

# Upgrade SailfishOS:
version --dup
The upgrade will take a very(!) long time and might not complete correctly. The upgrade might hang @ about 70% or 80% (I don't remember). There should be some posts in the CM12 thread.

In case it hangs, do...

Code:
# Stop upgrade process and sync the installed files
<ctrl>c
sync

# Force a shutdown (long press power) in case you cannot shutdown the system normally.

# Reboot and continue with 'version --dup'
version --dup
 

The Following User Says Thank You to minimec For This Useful Post:
Posts: 270 | Thanked: 426 times | Joined on May 2015 @ Italy
#313
Originally Posted by minimec View Post
There are some things to mention. The last running version of SailfishOS on the CM12 base is 2.0.5.6 Haapajoki (@claustn: correct me if I am wrong ;-) ) You will also have to add a systemd service to enable bluetooth low-power-mode (see next post)
I think you know better than me about Sailfish OS and its versions! I am still a beginner in the Linux world.

Anyway, is it possible to use the new LPM script version in the old CM12? Thank you for your work!
 

The Following 2 Users Say Thank You to claustn For This Useful Post:
Posts: 89 | Thanked: 286 times | Joined on Feb 2012 @ Switzerland
#314
Originally Posted by claustn View Post
Anyway, is it possible to use the new LPM script version in the old CM12? Thank you for your work!
Sure. I use it on CM12 right now. Just 'curl' the two files, make the script executable and enable/start the service.
 

The Following 2 Users Say Thank You to minimec For This Useful Post:
Posts: 270 | Thanked: 426 times | Joined on May 2015 @ Italy
#315
I get this error:
Code:
systemctl enable bt-sleep-monitor-ng.service
failed to get D-Bus connection: Failed to authenticate in time.
EDIT:
Solved with:
Code:
pkcon install dbus
systemctl enalble dbus.service
systemctl start dbus.service

Last edited by claustn; 2018-05-17 at 20:45.
 

The Following 2 Users Say Thank You to claustn For This Useful Post:
Posts: 89 | Thanked: 286 times | Joined on Feb 2012 @ Switzerland
#316
Originally Posted by claustn View Post
I get this error:
Interesting fact! I do indeed start the script with a different service on CM12, as I set some different undervolting table and max frequency settings and other stuff at the same time. I do now that the service works with CM13 however, as I tested it.

You can start the script manually after boot. That way, you even have a monitor of the events, as long as you keep the console open. :-)

Just do the following command in the console...
Code:
devel-su bt-sleep-monitor start
I will look for a solution and post the answer in the CM12 thread... ;-)
 

The Following User Says Thank You to minimec For This Useful Post:
Posts: 270 | Thanked: 426 times | Joined on May 2015 @ Italy
#317
Originally Posted by minimec View Post
Interesting fact! I do indeed start the script with a different service on CM12, as I set some different undervolting table and max frequency settings and other stuff at the same time. I do now that the service works with CM13 however, as I tested it.

You can start the script manually after boot. That way, you even have a monitor of the events, as long as you keep the console open. :-)

Just do the following command in the console...
Code:
devel-su bt-sleep-monitor start
I will look for a solution and post the answer in the CM12 thread... ;-)
The solution was installing dbus! I tried rebooting and --get-suspend-stats gives me good values, that means it works! Well done
 

The Following User Says Thank You to claustn For This Useful Post:
Posts: 89 | Thanked: 286 times | Joined on Feb 2012 @ Switzerland
#318
Originally Posted by claustn View Post
The solution was installing dbus! I tried rebooting and --get-suspend-stats gives me good values, that means it works! Well done
Good news! Although I wonder that you had to install dbus... ?!?
 

The Following User Says Thank You to minimec For This Useful Post:
Posts: 270 | Thanked: 426 times | Joined on May 2015 @ Italy
#319
Maybe there was something broken and reinstalling fixed it, who knows.
 

The Following User Says Thank You to claustn For This Useful Post:
Posts: 418 | Thanked: 1,130 times | Joined on Feb 2014 @ Germany
#320
@minimec

The OTA update problems of CM12.1 base are history in CM13 base version, update does not crash or take a long time anymore.

Thanks for your updated script!
 

The Following 3 Users Say Thank You to mautz For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 13:38.