Active Topics

 



Notices


Reply
Thread Tools
Posts: 21 | Thanked: 30 times | Joined on Nov 2018
#1
Hi,
I have problems while installing Modrana on my new N900.

The packages
libespeak (1.46.22) and espeak-data (1.46.22) are needed but not installed.

Where can I get these packages? And how I have to install them? I'm not very firm in Linux and a newbie on N900.

Thanks!
 

The Following User Says Thank You to 1896er For This Useful Post:
Posts: 302 | Thanked: 676 times | Joined on Aug 2011 @ suncity
#2
Originally Posted by 1896er View Post
Where can I get these packages? And how I have to install them?
Code:
apt-get install espeak
should solve the problem; at least
Code:
apt-get install libespeak espeak-data
If that does not help than you should check your repository settings or at least you can download packages from here and then manually install those with root access and
Code:
dpkg -i
.

Btw. the modrana version that is in maemo repos isn't the latest; I can confirm that the latest version on github works on n900 (thanks MartinK )
 

The Following 2 Users Say Thank You to justmemory For This Useful Post:
pichlo's Avatar
Posts: 5,648 | Thanked: 17,612 times | Joined on Sep 2012 @ UK
#3
Originally Posted by 1896er View Post
Where can I get these packages?
From Extras: http://repository.maemo.org/extras/p...free/e/espeak/

You do not get them from my link. It is just for demonstration that they are available. You make sure you have Extras included in your App Manager and then just install Modrana the normal way. It will pull all dependencies automatically.

Alternatively, do as justmemory says and install them manually from the command line.
__________________
In particle accelerators atoms are indeed not only touching each others. But banging together in a massive explosive orgasm.
-- nieldk in a TMO post
 

The Following 2 Users Say Thank You to pichlo For This Useful Post:
Posts: 2,255 | Thanked: 4,035 times | Joined on Apr 2010 @ England
#4
Just make sure you have working Extras and Nokia repos and they should install fine through the application manager.
__________________
The stable-beast currently runs...
21.2011.38-1Smaemo8 (CSSU Stable)
2.6.28.10power53 (125-600Mhz SR VDD1&2)

Wiki Admin
sixwheeledbeast's wiki
Testing Squad Subscriber
- mcallerx - tenminutecore - FlopSwap - Qnotted - zzztop - Bander - Fight2048 -


Before posting or starting a thread please try this.
 

The Following 3 Users Say Thank You to sixwheeledbeast For This Useful Post:
Posts: 21 | Thanked: 30 times | Joined on Nov 2018
#5
They are two repositories enabled: Community SSU and Maemo.org.
Disabled are Community SSU (testing), Community SSU (devil) and Community SSU (thump). The three Nokia repos not work. I've disabled them.
There isn't any "Extra" repository...? How can I include it?

I found this in the wiki:
The Extras repository is pre-configured on the N900 and listed as maemo.org and is enabled by default in PR1.1.

But maemo.org repo is enabled... And Modrana install failed...

Last edited by 1896er; 2018-11-08 at 13:45.
 

The Following User Says Thank You to 1896er For This Useful Post:
Posts: 2,255 | Thanked: 4,035 times | Joined on Apr 2010 @ England
#6
You need at least community extras and nokia repos working to have the application manager work correctly.
There are mirrors about to get the nokia ones back up, have a look on the forum and wiki for links.
You can check which packages are available for which repos at maemo.org/packages
__________________
The stable-beast currently runs...
21.2011.38-1Smaemo8 (CSSU Stable)
2.6.28.10power53 (125-600Mhz SR VDD1&2)

Wiki Admin
sixwheeledbeast's wiki
Testing Squad Subscriber
- mcallerx - tenminutecore - FlopSwap - Qnotted - zzztop - Bander - Fight2048 -


Before posting or starting a thread please try this.
 

The Following 3 Users Say Thank You to sixwheeledbeast For This Useful Post:
pichlo's Avatar
Posts: 5,648 | Thanked: 17,612 times | Joined on Sep 2012 @ UK
#7
Originally Posted by 1896er View Post
But maemo.org repo is enabled...
But is it set up properly? It should look something like this:
Code:
[catalogues]
catalogues = extras

[extras]
name = maemo Extras
uri = http://repository.maemo.org/extras/
components = free non-free
See also sixwheeledbeast's reply above.
__________________
In particle accelerators atoms are indeed not only touching each others. But banging together in a massive explosive orgasm.
-- nieldk in a TMO post
 

The Following 2 Users Say Thank You to pichlo For This Useful Post:
Posts: 21 | Thanked: 30 times | Joined on Nov 2018
#8
I have to add the "extras" catalogue manually in application manager? I can't see any extra repo now...
 

The Following User Says Thank You to 1896er For This Useful Post:
Posts: 21 | Thanked: 30 times | Joined on Nov 2018
#9
So, I'm sorry: YES, the extra-repository was installed! It is named: Maemo.org.

But Modrana can't be installed...

Ok, but now I have to search for the Nokia repos...
 

The Following User Says Thank You to 1896er For This Useful Post:
Posts: 21 | Thanked: 30 times | Joined on Nov 2018
#10
Here is a reply from a forum's member in another thread. I think, this is the problem:

The problem is, that espeak is in an inconsistent state in the extras repository. [1]
The newest version of the espeak package there is 1.46.22, while for its dependencies espeak-data and libespeak the newest version is 1.46.27. espeak needs exact version matches for its dependencies, but since apt-get tries to install the most recent version, this creates a conflict that can't be resolved.

dirty stopgap:
A: Manually download and install the three packages in version 1.46.22.
B: Install espeak from extras-devel, where espeak is in a consistent state. [2]


I need versions 1.46.27 from espeak, espeak-data and libespeak. If I want do download and install from extras-devel, which version is right for me: i386.deb or armel.deb?

Edit: I found the answer myself. BUT: If I try to install libespeak 1.46.27 from here: http://repository.maemo.org/extras-d...free/e/espeak/

App-Manager will NOT install it, cause the catalogue (repo) is not compatible... I have enabled all repos on the phone: CSSU, CSSU testing, CSSU devel and CSSU thump...

Any idea?

Thanks!

Last edited by 1896er; 2018-11-08 at 16:50.
 

The Following User Says Thank You to 1896er For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 09:34.