Active Topics



Thread Tools
Posts: 5 | Thanked: 0 times | Joined on Jan 2009
Hi all,
I have a N800. In the past I update without a problem from OS2007 to 0S2008.
I am now trying to update to Diablo.Following the instructions in
I try with a Linux machine, using flasher3
It stop in "Suitable USB device not found, waiting"
and keep waiting... nothing else happened.
Then I tried with a Mac. I downloaded flasher 770.
Same thing "Suitable USB device not found, waiting"
and keep waiting... nothing else happened.
Then my last shot, using a MSWindows XP.
I downloaded the update wizard from Nokia.
When it came to the part to start...never start.
It appears a Windows message, about USB device unknown.
I tried using different USB ports with the same result.
I've also checked the settings on the N800 about allowing connections not only WLAN.
I also tried another USB cable (not a Nokia one...)
I am lost... any help is welcome.

Last edited by sorgud; 2009-01-12 at 05:00.
pycage's Avatar
Posts: 3,404 | Thanked: 4,473 times | Joined on Oct 2005 @ Germany
When it says
Suitable USB device not found, waiting
it's time to turn on the tablet. The flasher will then continue.
Posts: 5 | Thanked: 0 times | Joined on Jan 2009
I did turn it on (holding the home key).
I guess it's a problem with the usb "mode" some host or peripherical switch mode, misplaced. 'cause I can not "see" the SDcard when I simple put the USB cable plugged to the pc
thanks anywey
Andre Klapper's Avatar
Posts: 1,665 | Thanked: 1,649 times | Joined on Jun 2008 @ Praha, Czech Republic
Originally Posted by sorgud View Post
I did turn it on (holding the home key).
Does it display the Nokia logo and the USB icon in the corner? Please describe exactly...
__________________ Bugmaster
Posts: 5 | Thanked: 0 times | Joined on Jan 2009
I follow all the steps in maemo how to.
I have the N800 with the maemo Linux based OS2008 Version 2.2007.50-2
When I get to the steps of start flashing, the "Suitable USB device not found, waiting" message appear.
I turn on the N800 (holding the home key). The USB symbol appear on the right corner on the N800.
And nothing else.
I believe that it is a problem with the USB control package.
When I connect the N800 with a PC I can't see the N800 as a mass storage (or anything).
I uninstalled the package and nothing changed. I tried to manually change the USB mode, with no luck.
In fact, things are getting worst.
Now the N800 can't see the extra SSD ( I can read it from a card reader in the Linux box) and I can't input a single letter from the bluetooth keyboard (it is recognized OK)....
If there were a way to roll a fresh install (without USB cable, and without using the extra SD card) I thing it will be the only way..
Posts: 678 | Thanked: 197 times | Joined on Jul 2007 @ San Jose CA
Try to delete the Nokia Flasher Software on your Windows machine and install the newest package from the Nokia site. That would help.
Posts: 5 | Thanked: 0 times | Joined on Jan 2009
It is the newest flasher.
And, as I explain in the first posting, I tried in Linux, MacOSX and MSWindows.... so I am completly sure it is not a problem in the flasher side... it is in n800.
BTW.... things are getting worse. Now, not only I can't see the SD cards, nor see them in a PC (as a mass storage) .. I can not use any intput but for the touch screen, the bluetooth keyboard doesn't work
(bluetooth is OK) the hardware keys don't work (home, back, up, down, etc. none!).
I think I will have to flash for a fresh start... but I don't know how to do it without USB connection....I'll google.

thanks anyway
Posts: 234 | Thanked: 40 times | Joined on Nov 2007 @ Cincinnati, Ohio USA
Could be host mode setting? I would think the home key would override that though.
Here is the wiki on resetting it without the easy switch software (if you have the software installed us that in the event there is a conflict).

Thread Tools

Forum Jump

All times are GMT. The time now is 15:15.