Notices


Reply
Thread Tools
pursueky's Avatar
Posts: 191 | Thanked: 46 times | Joined on Jun 2010 @ NanJing China
#821
is there any possible to make it boot ignore u-boot
 
Posts: 1 | Thanked: 0 times | Joined on Jul 2017
#822
Let me start off by saying I just got a Nokia N900 so I am a complete beginner.

Sorry if I am missing something but I attempted to try and get the u-boot-flasher and everything installed via apt-get install and Hildon Application Manager

Via Hildon Application Manager I receive "!!!U-Boot with Kernel 2.6.28-omap1 breaks the 3rd party package policy" and check the details and its complaining about my kernel-modules

via apt-get install u-boot-flasher I get:

The following packages have unmet dependencies:
u-boot-flasher: Depends: kernel-modules (= 2.6.28-20103103+0m5) but 2.6.28-20101501+0m5 is to be installed
E: Broken packages

According to dpkg my kernel-modules version is 2.6.28-20101501+0m5

So how do I get my kernel-modules updated to 2.6.28-20103103+0m5?
 
Posts: 43 | Thanked: 49 times | Joined on Apr 2011 @ Ipoh, Malaysia
#823
Originally Posted by explit View Post
Thanks Pali, i compiled the latest
u-boot 2013.04-2 with attached kernel-2.6.28.10-cssu3

All steps were described at the top of this post, the only problem was to find
the package: sdk-fiasco-gen
As soon as i had this package installed - it was not so complicated.
I noticed your advice and disabled cssu-devel in my Repos.

Now i have this items in U-Boot-Menu:

Kernel-2.6.28.10-power53 (default boot entry)
U-Boot with attached Kernel-2.6.28.10-cssu3 (Internal NAND)
Kernel-2.6.28.10-cssu3
U-Boot 2013.04-2

Ok i can't go back to the stock PR1.3 kernel-2.6.28-omap1 but i think, i can leave without it.

Thank you for your help !
Hi @explit,

Will it be possible to share the uboot binary you had compiled with attached cssu kernel. I am facing the same issue as posted by you.
 

The Following 2 Users Say Thank You to MetalGearSolid For This Useful Post:
Posts: 31 | Thanked: 24 times | Joined on Jan 2014 @ Hamburg
#824
Hi,
my N900 broke (GSM modem) and so I got a new one. I say new because its seems to be not used. But the former owner installed U Boot and some other random stuff.
He is not sure what he has done because it was three years ago.
So I want to revert to the stock kernel and then intall kernel power like before on my broken phone.
Now when I try to do the "open keyboard press u start the phone" thing I get the U Boot menu.
How do I proceed? Tried to find the info in this thread but with 80 pages I might have missed it.

EDIT: I am stupid. I should not press the power button while pressing U. I thought I had to. Just pressing U and connecting the USB works...

Last edited by sirvival; 2018-01-03 at 19:12.
 

The Following 3 Users Say Thank You to sirvival For This Useful Post:
Posts: 2 | Thanked: 1 time | Joined on Jul 2018
#825
Originally Posted by devzspy View Post
Let me start off by saying I just got a Nokia N900 so I am a complete beginner.

Sorry if I am missing something but I attempted to try and get the u-boot-flasher and everything installed via apt-get install and Hildon Application Manager

Via Hildon Application Manager I receive "!!!U-Boot with Kernel 2.6.28-omap1 breaks the 3rd party package policy" and check the details and its complaining about my kernel-modules

via apt-get install u-boot-flasher I get:

The following packages have unmet dependencies:
u-boot-flasher: Depends: kernel-modules (= 2.6.28-20103103+0m5) but 2.6.28-20101501+0m5 is to be installed
E: Broken packages

According to dpkg my kernel-modules version is 2.6.28-20101501+0m5

So how do I get my kernel-modules updated to 2.6.28-20103103+0m5?
I am having the exact same issue, I have not been able to find a solution would anyone be able to guide us in the right direction?
 
Posts: 2,144 | Thanked: 8,409 times | Joined on May 2010
#826
2.6.28-20103103+0m5 is a version in the last firmware version PR 1.3 and PR1.3.1. So you first should update to last Maemo version and then install U-Boot.

Search for firmware files:
PR1.3.1 - RX-51_2009SE_21.2011.38-1_PR_COMBINED_MR0_ARM.bin
PR1.3 - RX-51_2009SE_20.2010.36-2_PR_COMBINED_MR0_ARM.bin

If you are hard hacker, you can find DEB packages in repository:
http://repository.maemo.org/pool/mae...free/k/kernel/
 

The Following 4 Users Say Thank You to pali For This Useful Post:
Posts: 2 | Thanked: 1 time | Joined on Jul 2018
#827
Originally Posted by pali View Post
2.6.28-20103103+0m5 is a version in the last firmware version PR 1.3 and PR1.3.1. So you first should update to last Maemo version and then install U-Boot.

Search for firmware files:
PR1.3.1 - RX-51_2009SE_21.2011.38-1_PR_COMBINED_MR0_ARM.bin
PR1.3 - RX-51_2009SE_20.2010.36-2_PR_COMBINED_MR0_ARM.bin

If you are hard hacker, you can find DEB packages in repository:
http://repository.maemo.org/pool/mae...free/k/kernel/
This solved my issue, thanks for the quick reply.
 

The Following User Says Thank You to bobn900 For This Useful Post:
Reply

Tags
bootmenu, u-boot

Thread Tools

 
Forum Jump


All times are GMT. The time now is 23:34.