Notices


Reply
Thread Tools
Posts: 122 | Thanked: 232 times | Joined on Nov 2012 @ Germany
#1
There's one thing I don't get. Why can't I lock the device manually when automatic locking is disabled?? (two question marks emphasizing my cluelessness)

To work around this I modified /usr/share/jolla-settings/pages/devicelock/devicelock.qml and added a timeout of 24 hours:
Code:
MenuItem {
    //% "1 day"
    text: qsTrId("1 Tag")
    visible: deviceLockSettings.maximumAutomaticLocking === -1
                || deviceLockSettings.maximumAutomaticLocking >= 1440
    onClicked: lockingCombobox.setAutomaticLocking(1440)
}
Code:
} else if (value === 1440) {
    return 6
but what? In 2.1.1.12 the device gets locked after around 3 hours automatically instead of one day.

So I don't see a chance to lock my device just manually. I have to set automatic locking to "not in use" and change it to "no delay" when i have to lock it. Strange.

But besides that I got quite convinced of th UI concept after two weeks of asking myself "why is there no real home screen (as in fremantle), which is launcher, switcher and events view in one"? In fact I'm already really happy with my Jolla C. Using it feels very smart to me.
__________________
OpenSSH Status Widget (N900)
Start / stop / kill / restart / autostart server - View server status - View server and client connections - Switch wifi pm automatically

Simpler Brightness Applet (N900) - A variation of the Simple Brightness Applet
Short tap to toggle "keep backlight on" - Long tap to open display settings
 

The Following User Says Thank You to rasmarc For This Useful Post:
coderus's Avatar
Posts: 6,068 | Thanked: 11,244 times | Joined on Nov 2011 @ Open Mobile Platform, Innopolis, Russia
#2
Did you tried fast doubleclick power button for device locking?
__________________
Twitter | Openrepos | GitHub | PayPal.Me
 

The Following 3 Users Say Thank You to coderus For This Useful Post:
Posts: 122 | Thanked: 232 times | Joined on Nov 2012 @ Germany
#3
Originally Posted by coderus View Post
Did you tried fast doubleclick power button for device locking?
Yes I did. When automatic locking is set to "not in use" double pressing the power button does nothing. Should it lock? Did I something put wrong?
__________________
OpenSSH Status Widget (N900)
Start / stop / kill / restart / autostart server - View server status - View server and client connections - Switch wifi pm automatically

Simpler Brightness Applet (N900) - A variation of the Simple Brightness Applet
Short tap to toggle "keep backlight on" - Long tap to open display settings
 

The Following 2 Users Say Thank You to rasmarc For This Useful Post:
nthn's Avatar
Posts: 543 | Thanked: 1,886 times | Joined on Jun 2014
#4
I just checked and I can reproduce your problem. Seems like a bug.
 

The Following 3 Users Say Thank You to nthn For This Useful Post:
coderus's Avatar
Posts: 6,068 | Thanked: 11,244 times | Joined on Nov 2011 @ Open Mobile Platform, Innopolis, Russia
#5
then you should report it to tjc for sure
__________________
Twitter | Openrepos | GitHub | PayPal.Me
 

The Following 2 Users Say Thank You to coderus For This Useful Post:
Posts: 122 | Thanked: 232 times | Joined on Nov 2012 @ Germany
#6
As a note, I wanted to set the dbus action for device locking to the power key using mcetool, but after figuring out the code with dbusinspector
Code:
dbus-send --system --type=method_call --dest=org.nemomobile.devicelock /devicelock org.nemomobile.lipstick.devicelock.setState int32:1
it turned out that the dbus signal also doesn't work when automatic locking is set to "not in use".
__________________
OpenSSH Status Widget (N900)
Start / stop / kill / restart / autostart server - View server status - View server and client connections - Switch wifi pm automatically

Simpler Brightness Applet (N900) - A variation of the Simple Brightness Applet
Short tap to toggle "keep backlight on" - Long tap to open display settings
 

The Following User Says Thank You to rasmarc For This Useful Post:
Reply

Thread Tools

 
Forum Jump


All times are GMT. The time now is 01:47.